Page 1 of 1

Uninstall issue

Posted: Sat Mar 10, 2012 6:08 pm
by mat_mar
Hi,
I installed for test installatron on RH6
The Install is working properly, but when uninstalling applications, tables are not deleted from the database.
This issues happens with any application, even if I get the message "Uninstall is complete".
Thanks in advance.
Marius

Re: Uninstall issue

Posted: Mon Mar 12, 2012 10:11 am
by Phil
Hello,

Sorry to hear about the problem. Tables that are associated with an installed application should be removed upon uninstallation.

Please try updating to the latest "edge" build to test if this improves the outcome. To update, execute this command from the SSH root command prompt:

Code: Select all

/usr/local/installatron/repair -f --edge

After updating, try a test WordPress install, and report back on whether tables are removed.

Thank you,
Phil.

Re: Uninstall issue

Posted: Mon Mar 12, 2012 10:49 am
by mat_mar
Hi,

Code: Select all

[root@localhost ~]# /usr/local/installatron/repair -f --edge
200 http://data1.installatron.com/installatron/repair
curl exit code: 0
Installatron Install & Repair Utility,
Rev. 2.4 (2009-04-09)

Internal PHP Binary: /usr/bin/php
Detecting supported Fetch drivers... done.

Choose a Fetch driver:
  [0] System CURL Binary /usr/bin/curl
  [1] PHP CURL Extension
Using: [0] System CURL Binary /usr/bin/curl

Testing ionCube loaders...
 - Existing loader: Testing... working.

Checking license...
PHP Binary Version: 5.3.3 (major version 5).....
done.

Detecting supported archive extraction handlers... done.

Choose a `tar.gz' archive extraction handler:
  [0] /bin/tar
  [1] PHP zlib Extension via Archive_Tar
Using: [0] /bin/tar

Choose a `zip' archive extraction handler:
  [0] /usr/local/installatron/lib/unzip
  [1] PHP zip Extension
Using: [0] /usr/local/installatron/lib/unzip

Configuring Installatron Server wrapper... done.

Checking for existing Installatron Server install... detected v2.2.0.

Downloading Installatron Server 2.2.0 (latest edge) core... done.

Installing... done.

Updating Locale... done.

Updating Installers...  - mediawiki updated
 - moodle updated
 - opencart updated
done.

Finished Repairing and Updating Installatron Server.

After that, I tried a test WordPress install, and no table has been deleted.
Thanks

Re: Uninstall issue

Posted: Tue Mar 13, 2012 3:55 am
by Phil
Hello,

I haven't been able to reproduce this. Is the affected website using a FTP path or a local path? Was the database empty prior to the install or did the database already contain database tables?

Please open a ticket and include the output of this command:

Code: Select all

cat /usr/local/installatron/etc/settings.ini


Thank you,
Phil.

Re: Uninstall issue

Posted: Fri Mar 04, 2016 5:23 am
by webinformation
thank you. i solved this problem in my server.