WP 2.8 to 2.8.1 Upgrade Query

Regarding problems encountered while using the website owner interface.
confuscius
Posts: 6
Joined: Sat Jun 06, 2009 10:49 am
Location: Felixstowe UK

WP 2.8 to 2.8.1 Upgrade Query

Postby confuscius » Fri Jul 10, 2009 2:10 am

I am seeing the following when trying to upgrade a WP 2.8 installation :

"! The selected version, or a version between it and the installed version, does not support upgrading. Check the application's website to see if a "migration" tool is available."

Any idea what the issue is that is causing this message?

*** UPDATE *** This is caused by the fact that this version of WP was not enabled within installatron because I only have latest WP versions enabled, so the version shows as available but it is not because it is not enabled! A little confusing! Issue resolved by enabling the specific WP version - I will probably not be alone in hitting this issue.

Phil
Staff
Posts: 486
Joined: Tue Jun 19, 2007 6:06 am

Re: WP 2.8 to 2.8.1 Upgrade Query

Postby Phil » Sat Jul 11, 2009 11:57 pm

Hello,

New versions are automatically enabled if the prior version is also enabled. In this case, if WordPress 2.8 was enabled then 2.8.1 should have been enabled automatically. If this did not occur then the Installatron Update process was terminated prematurely. If this happens for every Installatron Update I recommend opening a ticket.

Thanks,
Phil.
Phillip Stier
Installatron Co-Founder

confuscius
Posts: 6
Joined: Sat Jun 06, 2009 10:49 am
Location: Felixstowe UK

Re: WP 2.8 to 2.8.1 Upgrade Query

Postby confuscius » Sun Jul 12, 2009 2:10 am

Hi Phil

In my case, only certain WP versions were enabled, back to v 2.7 only. Version 2.8.1 was showing as available for install BUT it was showing as disabled until I manually enabled it. I tried the installation more that once so do no not believe that it was terminating early.

Could it be that if ALL previous versions are enabled then the latest one is automatically enabled but if SOME previous versions are enabled then the latest one is NOT automatically enabled?

This is not an issue for me as it only takes a few seconds to manually enable a new version.

Phil
Staff
Posts: 486
Joined: Tue Jun 19, 2007 6:06 am

Re: WP 2.8 to 2.8.1 Upgrade Query

Postby Phil » Sun Jul 12, 2009 6:11 am

Hello,

The updater only checks the previous version. If 2.8 was enabled then 2.8.1 should have been enabled automatically.

If this behavior continues in the future let us know.

Thanks,
Phil
Phillip Stier
Installatron Co-Founder


Return to “Website Owner Technical Discussion and Troubleshooting”

Who is online

Users browsing this forum: No registered users and 5 guests