SugarCRM Install Issue

Regarding problems encountered while using the website owner interface.
markb1439
Posts: 48
Joined: Wed Dec 17, 2008 5:30 pm

SugarCRM Install Issue

Postby markb1439 » Fri Jun 05, 2009 9:43 pm

Hi,

After installing SugarCRM with Installatron, I see the famous "undefined" issue...this means that, in many places throughout SugarCRM, the word "undefined" appears instead of a text string. For example, if you remove a dashlet, normally you see a dialog with a message like, "Are you sure you want to remove the Sugar dashlet?" But instead, the dialog just says "undefined."

This is generally caused by the cache folder not being writable (644 for files, 755 for directories). Would you consider changing the installer so that these permissions are set properly? (I think the problem is not necessarily in Installatron, because Sugar's own installers are notorious for failing to set the cache permissions as needed.)

In the meantime, the fix is to set the permissions manually in FileZilla, via command line or otherwise.

Best regards,

Mark

Phil
Staff
Posts: 486
Joined: Tue Jun 19, 2007 6:06 am

Re: SugarCRM Install Issue

Postby Phil » Sat Jun 06, 2009 8:02 am

Hi,

We'll look into this and let you know what we find.

Thanks,
Phil.
Phillip Stier
Installatron Co-Founder

Phil
Staff
Posts: 486
Joined: Tue Jun 19, 2007 6:06 am

Re: SugarCRM Install Issue

Postby Phil » Sat Jun 06, 2009 12:15 pm

Hi again,

I installed SugarCRM on a few test systems today however was not able to replicate anything. In the tests, the "cache" directory was properly set to chmod 0777, and locale texts did display correctly. Perhaps you can open a ticket and provide us access to an account for further testing.

Thank you,
Phil.
Phillip Stier
Installatron Co-Founder


Return to “Website Owner Technical Discussion and Troubleshooting”

Who is online

Users browsing this forum: No registered users and 3 guests