Page 1 of 1

Upgrade to Joomla 1.5.10 not available

Posted: Tue Apr 28, 2009 3:21 am
by blacknight
Hi guys. A customer of ours on a shared server using PHP Version 4.4.2 can't upgrade his Joomla install to 1.5.10. His current version is 1.5.7. The error he's getting is:

! The hosting server does not meet the requirements of this version of this application, so this version cannot be upgraded to. Server configurations are many and varied, and not all applications (or versions of an application) will work on all servers. (php-version-minimum)


Has anyone else had similiar problems like this? I can't see anything about specific Joomla PHP requirements for 1.5.10 and the lowest version they say they require on the website is PHP 4.3 so the server should meet that.

This looks to be an issue with PHP version 4.4.2 and 4.4.4 at least and possibly either Installatron or Joomla as in the Installatron admin it's saying Joomla 1.5.x is disabled because of the same error above however the customer was able to install 1.5.7 on it previously... possibly before the upgrade to Installatron 6.

Re: Upgrade to Joomla 1.5.10 not available

Posted: Tue Apr 28, 2009 3:28 am
by rlshosting
Here you go:
http://help.joomla.org/content/view/1938/310/

Try PHP 4.4.7

Do not use PHP 4.3.9, PHP 4.4.2 or PHP 5.0.4; these releases have known bugs that will interfere with the installation of Joomla! There was also an issue with the Zend Optimizer Version 2.5.10 for PHP 4.4.x. You should ask your host to upgrade to a later release as soon as possible where applicable.
If you experience problems with Joomla! on other versions of these source server programs please take the time to check out the changelogs for your particular version, as there are often good indicators of the likely cause of issues. If there is a particular problem identified you need to notify your Host provider and encourage them to update the affected program

Re: Upgrade to Joomla 1.5.10 not available

Posted: Tue Apr 28, 2009 3:39 am
by Rowan
Hello,

Yes, Installatron has a minimum requirement of PHP 4.4.7 on Joomla 1.5 as there are versions before that which do not work correctly with Joomla.

You can override this in Installatron from Administration >> Catalogs.

However 4.4.2 is a version that has known problems so I'd recommend upgrading PHP rather than overriding via Catalogs.

Rowan.

Re: Upgrade to Joomla 1.5.10 not available

Posted: Tue Apr 28, 2009 4:16 am
by blacknight
ah right. I'll ask the engineers to upgrade to a newer version of PHP 4 so if they can. That particular server is running Tomcat also so I think the engineers might be avoiding doing this ;)