Auto backup of sql gives empty file

For urgent and private issues, open a support ticket instead of posting: https://secure.installatron.com/tickets
ozfiddler
Posts: 6
Joined: Fri Nov 15, 2013 2:38 am

Auto backup of sql gives empty file

Postby ozfiddler » Thu Apr 03, 2014 7:54 pm

I recently moved all my sites (WP and Joomla) to a new server. I do this by using the last daily backup of each site - I upload the files and then import the database. On one of my WP sites I imported the database and found it was just an empty file... completely blank. I checked back through some other daily backups of this site and found that in each case a file called APP-DATA.SQL had been created in the backup folder but it was 0kb in size. Nothing there.

This is very worrying because I use Installatron as my main backup routine on all my sites. All the other sites were fine, just this one. Does anyone know why this might be happening... or, more importantly, how to make sure it doesn't ever happen!

Phil
Staff
Posts: 486
Joined: Tue Jun 19, 2007 6:06 am

Re: Auto backup of sql gives empty file

Postby Phil » Fri Apr 04, 2014 4:57 pm

Hello,

I understand the concern. On the "edit" page for the installed app check the "Files & Tables" tab. What does the table selection look like for the affected install?

Thank you,
Phil
Phillip Stier
Installatron Co-Founder

ozfiddler
Posts: 6
Joined: Fri Nov 15, 2013 2:38 am

Re: Auto backup of sql gives empty file

Postby ozfiddler » Sat Apr 05, 2014 3:04 am

Well done Phil... you found the problem Immediately! The database prefix wasn't correct. This must have come from me using Better WP Security (one of the things it does is change the database prefix from the standard wp_), and it probably carried over from last time I moved the website. I must have somehow imported a wrong configuration file. Easily fixed anyway, and I'll just go through and check the others to make sure they are OK as well.

That's good... I can still trust Installatron. :-)

Thanks for your help.


Return to “Administrative Technical Discussion and Troubleshooting”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests