Plesk 11.5 and preferred subdomains

For urgent and private issues, open a support ticket instead of posting: https://secure.installatron.com/tickets
Post Reply
jas8522
Posts: 61
Joined: Sat Jul 24, 2010 4:25 pm

Plesk 11.5 and preferred subdomains

Post by jas8522 » Sat Mar 29, 2014 12:51 pm

In Plesk 11, Parallels added an option for every domain that specifies the subdomain to be used. It's an option called "Preferred Domain" that has the options: None, http://www.domain.tld, and domain.tld

It seems that when a customer adds a new domain, it will occasionally default to 'domain.tld' without anyone noticing (or they don't know what it means).

When they then install WordPress (and possibly other apps) they select http://www.domain.tld and it winds up creating an infinite redirect loop wherein Plesk 301s http://www.domain.tld to domain.tld but WordPress forces http://www.domain.tld ad infinitum.

I'm wondering if it might be possible to check the status of the "Preferred Domain" field and only allow the user to install the app according to that setting. Here's how it would work:

1. When preferred domain is "None" Installatron behaves exactly as it does now -- giving the option
2. When preferred domain is "domain.tld", Installatron only provides domain.tld as an installation option
3. When preferred domain is "www.domain.tld", Installatron only provides http://www.domain.tld as an installation option

Thanks for your help with this!

Jordan

Phil
Staff
Posts: 490
Joined: Tue Jun 19, 2007 6:06 am

Re: Plesk 11.5 and preferred subdomains

Post by Phil » Sun Mar 30, 2014 11:27 pm

Jordan,

Thanks for letting us know about this issue. We'll get this fixed for the next Edge release channel build (ETA is early this week).

Thank you,
Phil
Phillip Stier
Installatron Co-Founder

jas8522
Posts: 61
Joined: Sat Jul 24, 2010 4:25 pm

Re: Plesk 11.5 and preferred subdomains

Post by jas8522 » Tue Apr 01, 2014 12:49 pm

Sounds great! Thanks Phil :)

jas8522
Posts: 61
Joined: Sat Jul 24, 2010 4:25 pm

Re: Plesk 11.5 and preferred subdomains

Post by jas8522 » Thu Jun 19, 2014 1:32 pm

Did this make it in to the current stable release?

I'm still seeing reports of it being an issue with 9.1.3

Phil
Staff
Posts: 490
Joined: Tue Jun 19, 2007 6:06 am

Re: Plesk 11.5 and preferred subdomains

Post by Phil » Wed Jun 25, 2014 7:19 pm

Hello,

Sorry for the wait. This is fixed on the Edge release channel. To update now:

Code: Select all

/usr/local/installatron/repair -f --edge --quick
If any issues persist let us know.

Thank you,
Phil
Phillip Stier
Installatron Co-Founder

Post Reply