[Bug] Plugin v9 and multi-upgrade

For urgent and private issues, open a support ticket instead of posting: https://secure.installatron.com/tickets
interfaSys
Posts: 78
Joined: Thu Jan 05, 2012 10:56 am

Re: [Bug] Plugin v9 and multi-upgrade

Post by interfaSys » Tue Jan 21, 2014 9:04 am

There is nothing but successful completion messages in the logs. That's the thing I don't understand.

/var/installatron/logs/filesystem_log

Code: Select all

2014-01-21T14:45:04+01:00 SUCCESS rm(/public_html/deleteme.l5ryyhnw.php) - code: core_unlink($path);
2014-01-21T14:45:04+01:00 SUCCESS rm(public_html/deleteme.lejfdy1k.php) - code: core_unlink($path);
2014-01-21T14:45:12+01:00 SUCCESS rm(/var/installatron/cache/cil_current_5D8P8W) - code: core_unlink($path);
2014-01-21T14:45:12+01:00 SUCCESS rm(/var/installatron/cache/cil_current_5s3ejezc2akgwocgows84sswk) - code: core_unlink($path);
2014-01-21T14:45:16+01:00 SUCCESS rm(public_html/deleteme.srni9low.php) - code: core_unlink($path);
2014-01-21T14:45:16+01:00 SUCCESS rm(/public_html/deleteme.ocrbahx1.php) - code: core_unlink($path);
/var/installatron/logs/fetch_log

Code: Select all

2014-01-21T14:45:04+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain1.com/deleteme.l5ryyhnw.php
2014-01-21T14:45:04+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain2.com/deleteme.lejfdy1k.php
2014-01-21T14:45:12+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain2.com/deleteme.wp88ja.php
2014-01-21T14:45:12+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain1.com/deleteme.wpuarr.php
2014-01-21T14:45:16+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain2.com/deleteme.srni9low.php
2014-01-21T14:45:16+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain1.com/deleteme.ocrbahx1.php
2014-01-21T14:45:24+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain2.com/deleteme.wpkjs7.php
2014-01-21T14:45:24+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain1.com/deleteme.wpq7m8.php
2014-01-21T14:45:35+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain2.com/deleteme.wpp046fdf46ce5f40b4b26d861c3d9b5ddb.php
2014-01-21T14:45:35+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain1.com/deleteme.wpp1b3669a7ae194c0ab05f47c5bcca5c7d.php
2014-01-21T14:45:43+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain2.com/deleteme.wpgaud.php
2014-01-21T14:45:44+01:00 SUCCESS [3; /usr/local/bin/curl] http://domain1.com/deleteme.wpfrlh.php
/var/installatron/logs/plugintheme_log

Code: Select all

2014-01-21T14:45:35+01:00 [false true true] array ( 0 => '
...
 cms-tree-page-view/index.php: updated; csv-importer/csv_importer.php: updated;
...
And yet, both Installatron and WP show me that the plugins have not been updated.
The domains logs show no errors.
Olivier
interfaSys
Web, mobile, hosting product and service development experts

interfaSys
Posts: 78
Joined: Thu Jan 05, 2012 10:56 am

Re: [Bug] Plugin v9 and multi-upgrade

Post by interfaSys » Tue Jan 21, 2014 9:33 am

I just did a test on a WP site installed by Installatron and there were no issues.
It's also a network, but doesn't have any sub site installed.

The main difference between these 2 setups is that I think the one which fails was imported into Installatron.
It also has a lot more plugins.
Olivier
interfaSys
Web, mobile, hosting product and service development experts

Phil
Staff
Posts: 490
Joined: Tue Jun 19, 2007 6:06 am

Re: [Bug] Plugin v9 and multi-upgrade

Post by Phil » Thu Jan 23, 2014 3:09 pm

Hello,

On this server do PHP files execute under the user's account or the web server UID?

If it isn't there already, try adding this to the wp-config.php file:

Code: Select all

define('FS_METHOD','direct');
Also check the permissions and ownership on the install's wp-content/plugins directory. Under some server configurations these files have wonky permissions/ownership that prevent upgrades. However, for the past couple versions Installatron has the ability to automatically fix these permissions, so something isn't working right if this is the cause.

If possible, open a ticket proving login information for the web hosting account hosting for this install and we'll investigate this on your behalf.

Thanks,
Phil
Phillip Stier
Installatron Co-Founder

interfaSys
Posts: 78
Joined: Thu Jan 05, 2012 10:56 am

Re: [Bug] Plugin v9 and multi-upgrade

Post by interfaSys » Thu Jan 23, 2014 3:37 pm

Hello Phil,

Not sure if it's because of a recent plugin update or something else, but I was able to update the plugins of all networks last night.
Another reason could be that I re-enabled W3 cache after it had been broken in a recent upgrade.

I'll wait for the next round of plugin updates notifications before confirming that everything is working properly.

I've checked the configs for

Code: Select all

define('FS_METHOD','direct');
and one WP network doesn't have it. I'll leave it as is for now to see if it's irrelevant or indeed needed.

Thank you for Installatron :)

Cheers,

Olivier
Olivier
interfaSys
Web, mobile, hosting product and service development experts

Phil
Staff
Posts: 490
Joined: Tue Jun 19, 2007 6:06 am

Re: [Bug] Plugin v9 and multi-upgrade

Post by Phil » Fri Jan 24, 2014 3:07 pm

Olivier,

Great to hear it's working. It's possible 9.0.7 fixed this as that version really had a lot of fixes.

Cheers,
Phil
Phillip Stier
Installatron Co-Founder

Post Reply