Resellers get wrong apps and backups counts

For Installatron Sales: sales@installatron.com
Post Reply
interfaSys
Posts: 78
Joined: Thu Jan 05, 2012 10:56 am

Resellers get wrong apps and backups counts

Post by interfaSys » Thu Jan 23, 2014 3:44 pm

Log in as a reseller and open installatron
Next to "My Applications and "My Backups", you have numbers which represent the number of installed apps and backups respectively.

On 9.0.7, resellers get the numbers from the server (admin) instead of their own.
Olivier
interfaSys
Web, mobile, hosting product and service development experts

Phil
Staff
Posts: 490
Joined: Tue Jun 19, 2007 6:06 am

Re: Resellers get wrong apps and backups counts

Post by Phil » Fri Jan 31, 2014 9:14 am

Hello,

It's correct for resellers to see owned-account installed applications included under that counter.

I actually haven't been able to reproduce this issue on a dev server. Under the reseller login, the total is inclusive of the reseller and owned accounts only, not all accounts on the server.

Can you double check this is definitely wrong?

Thanks,
Phil
Phillip Stier
Installatron Co-Founder

interfaSys
Posts: 78
Joined: Thu Jan 05, 2012 10:56 am

Re: Resellers get wrong apps and backups counts

Post by interfaSys » Fri Jan 31, 2014 10:19 am

Hello Phil,

I've investigated further. There is definitely a mismatch, but the numbers don't come from the admin account. It just so happen that this reseller has all the apps under his account.

At the reseller level in DA, click on Installatron.
The number at the top, 10, in the "My Applications" tab is the number of apps installed by all the accounts sold by the reseller, but the list below only shows the 4 apps owned by the reseller himself.

Now if I click on the "gears", then select "Installed Applications", I see all the apps installed by the reseller and the sub accounts: 10.

Now, at the user level, the Installatron section shows me the correct number of apps at that level: 4, but if I click on "view more", then I see 10 again in the tabs, but only 4 below and listing all apps (via the gears icon) shows me all 10.

Since "Installed Applications" is in the Admin section, I think it makes sense to show all apps, but there should be some consistency between what is shown in the tab and in the list below it.
If "My applications" is supposed to list all the apps installed by this account only, then the number should be 4.
The problem is that when clicking on "Installed Applications", we're redirected to the same tab, but in this case it's listing the apps installed by the reseller and all its sub-accounts.

So two issues:
- The number in the tab should match the number of apps in the list
- The name in the tab should maybe switch from "My" to "All", depending on what is being displayed in the list.

Cheers,

Olivier
Olivier
interfaSys
Web, mobile, hosting product and service development experts

Phil
Staff
Posts: 490
Joined: Tue Jun 19, 2007 6:06 am

Re: Resellers get wrong apps and backups counts

Post by Phil » Fri Jan 31, 2014 12:05 pm

Hello,

The total displayed on the tab is intended to be the total number of apps for the reseller and all owned-accounts.

Clicking the "magic wand" button under the My Apps tab toggles between showing all apps and just the reseller's own apps. The "installed applications" link from Administration loads My Apps with that button enabled.

We'll discuss the proposed recommendations and see what we can do to make this more straightforward.

Thanks,
Phil
Phillip Stier
Installatron Co-Founder

interfaSys
Posts: 78
Joined: Thu Jan 05, 2012 10:56 am

Re: Resellers get wrong apps and backups counts

Post by interfaSys » Fri Jan 31, 2014 12:23 pm

Hello Phil,

Got it and you're right: It has everything to do with the magic wand.

Cheers,

Olivier
Olivier
interfaSys
Web, mobile, hosting product and service development experts

Post Reply