Page 1 of 1

Wordpress 2.8

Posted: Thu Jun 11, 2009 4:03 am
by confuscius
Having recently had my first play with installatron, the ability to add custom code to an installer is simply a brilliant feature!

I was just wondering what is the normal timeframe before an installer for a new WP version becomes available? A day? A few days? A week? A month?

Congratulations on a superb piece of kit!

Re: Wordpress 2.8

Posted: Thu Jun 11, 2009 5:25 am
by Kirii
Actually you can upgrade it manually,there is such function at your wp-admin

Re: Wordpress 2.8

Posted: Thu Jun 11, 2009 7:48 am
by donnacha
confuscius wrote:I was just wondering what is the normal timeframe before an installer for a new WP version becomes available? A day? A few days? A week? A month?

They are usually very quick, faster than Fantastico, and everyone knew that 2.8 was being released yesterday, the Installatron guys are probably already working on it.

Kirii wrote:Actually you can upgrade it manually,there is such function at your wp-admin

I'm not sure but I suspect it would be safer to choose just one method to handle your upgrades - yes, you can do a one-button upgrade from within WordPress but if you have more than just a couple of blogs, Installatron upgrades will be faster and, again, sticking to one method will reduce the risk of unexpected problems.

Re: Wordpress 2.8

Posted: Thu Jun 11, 2009 10:00 am
by donnacha
Good news, they just tweeted that 2.8 has now been deployed!

You can follow Installatron @installatron but you can't Direct Message them because they don't follow back, the account will apparently be used only for announcements, which is a pity.

Re: Wordpress 2.8

Posted: Thu Jun 11, 2009 12:45 pm
by confuscius
Donnacha - many thanks for the info.

I have run the Installatron Repair/Update and WP 2.8 is present BUT it is showing as disabled! I then try to enable it and it says that the settings are saved BUT it still shows as disabled. I only have 2.7.0 and 2.7.1 enabled as available for installing because of previous security concerns. I do not believe that there are any technical changes in WP 2.8 that would conflict with my custom server set up that uses suPhp. Very strange!

Is this a bug or does it mean that Installatron is unable to upgrade WP from 2.7.1 to 2.8 at the present time?

Most likely a bug? Could anyone else confirm whether they have managed to get WP 2.8 showing as enabled in Installatron.?

Confuscius is confused but amazed at the speed with which this was deployed!

Re: Wordpress 2.8

Posted: Thu Jun 11, 2009 1:17 pm
by donnacha
confuscius wrote:I have run the Installatron Repair/Update and WP 2.8 is present BUT it is showing as disabled! I then try to enable it and it says that the settings are saved BUT it still shows as disabled.

Put a tick in the check box for 2.8 and click the "Enable" button at the bottom of the list.

confuscius wrote:I only have 2.7.0 and 2.7.1 enabled as available for installing because of previous security concerns. I do not believe that there are any technical changes in WP 2.8 that would conflict with my custom server set up that uses suPhp.

If you had no problems installing the previous versions via Installatron, 2.8 should not present any problems.

confuscius wrote:Most likely a bug? Could anyone else confirm whether they have managed to get WP 2.8 showing as enabled in Installatron.?

It as showing as enabled for me, having carried out the steps I outlined above.

I have not, however, had time to do any upgrades or installs yet, I'll get around to that in a few hours but I don't anticipate any problems.

confuscius wrote:Confuscius is confused but amazed at the speed with which this was deployed!

Yeah, they are very good, I hope they can keep up this level of service.

Re: Wordpress 2.8

Posted: Thu Jun 11, 2009 2:59 pm
by confuscius
Put a tick in the check box for 2.8 and click the "Enable" button at the bottom of the list.


That is exactly what I had done BUT it was still showing as disabled!!! I have now logged into whm from a different computer and it is showing as enabled - really strange one this as it seems that it had been enabled successfully so can only guess that possibly a session variable may not have been updating or something similar.

Thanks for prompting me to log in again as I may have sat here for days not realising that it had updated properly already!

Time to sort out some upgrade tweaks.

Thanks to everyone at Installatron for the brilliant service provided - it makes a refreshing change these days.

Re: Wordpress 2.8

Posted: Fri Jun 12, 2009 4:56 am
by eastitaly
I've tried to upgrade WP from 2.7.1 to 2.8 within Installatron at user's side, but in the version's selection page I get

! The selected version, or a version between it and the installed version, does not support upgrading. Check the application's website to see if a "migration" tool is available.


Could anyone else confirm this?

EDIT: Sorry, my fault. Forgot to checkout "Server-wide Settings" under "Dependencies"